New firmware update 1.4.1 available for the Nano S

ledgernanos
updates
firmware

#41

Updated in about 5 minutes, no issues by following the directions in the blog post


#42

Yeah, thanks. Just updated it now. Whew! Makes me think I should distribute my crypto on different wallets and kinds of wallets, instead of putting the bulk on just my Nano. Maybe Exodus, and others.


#43

The bottom line at Source : Reddit worked for me and all you have to do after following the instructions of the whole statement is to reinstall the ledger wallet apps then you are all set.


#44

It worked for me. I had to delete my apps and then I was able to do the update. No problem at all. Thanks


#45

Yep I had to remove my apps for the update buy it was no biggie as it only takes a few seconds to remove and reinstall


#46

Is anyone interested in the technical details of Saleem’s write-up, and how effectively does the 1.4.1 update neutralize those attack vectors?

As I understand it, an affected user would have to either a) ignore a ‘firmware inauthentic’ message upon initial setup (unless inauthentic message was changed by attacker), b) continue to use an inauthentic firmware, or c) download a counterfeit firmware upgrade.

So my TL;DR question: Does the 1.4.1 firmware upgrade neutralize all the vulns outlined by Saleem?


#47

Dunno? Just ignore the details I guess?


#48

I have the same problem, cannot update… windows 10


#49

where are you seeing the error? have you deleted all the apps off the device?


#50

Be aware that when contacting the Ledger Nano about the updates, they only make contact by email, no phone
they recommend if you are haveng trouble to move everything out and then finish the update


#51

Yes I deleted all the wallets, but the systems still show a message that its need more capacity.


#52

When I’m doing that, my Nano says: “MCU firmware not genuine”. Is this because I need to update, or could it be my Nano is not the real deal?


#53

Thx, Rick!
I’ll let you know how it works out.


#54

Thx for the support. I emailed ledger wallet support…Point two is what worked for me:

  1. Start the Ledger Manager.

  2. Simultaneously press both buttons three times to enter the dashboard in ‘unsafe mode’.

  3. When the Ledger Manager opens, download and install the latest firmware from the FIRMWARES tab.

  4. After the update select “No” when asked to “Initialize as new device?”

  5. Select “Yes” when asked to Restore configuration.