Fresh Win , brand new mobo...System freezes with 4 gpu's


#1

Hello folks!

I had several issues with a MSI motherboard that wasn’t supporting multiple vga’s properly so I changed it for a Asrock H110 Pro BTC +.

I fresh installed windows (prior to that I formatted the SSD). Did all the win tweaks (Disabled suspensions and HD turn off feature, configured the pc for max performance and disabled win update, Also set virtual mem to 16 gb), still windows freezes after some time, maybe hours maybe just one hour…sometimes after a day but won’t properly work on a 24/7 basis.

My guess: my EVGA Suprnova G2 1300 watts psu is not enough to feed all my Vga’s but…does that freeze your Pc? or Reboots it?

I’ve got 3 Nvidia Gtx 1080’s and one AMD R9 295x2 . The latter has a 500 watts TDP according to some hardware sites…so that’s almost 85% of my psu power capability, meaning that I’m going beyond the 80% max line…so now I’m running only 2 1080’s and the 295x2 to test it out. But I still wanted your points of view as many sets of eyes see more than just one, right?

I am using Bminer for CUDA and Claymore for the AMD card. Nvidia drivers 391.35 (as latest ones don’t get along with msi afterburner)

All is on stock settings, no OC.

Thanks a lot guys!


#2

Assuming there isn’t any hardware related issue, you may wish to check the BIOS settings:

Set VT-d INTEL VIRTUALIZATION to DISABLED.
Set ONBOARD AUDIO/SOUND (AZALIA) to DISABLED.
Set IEEE1394 to DISABLED.
Set IOMMU to DISABLED.

Then run it for a while see if freezing goes away.

If it behaves better, then start playing with your OC settings.

Stay Fishy


#3

Hey Mike!

Thanks for your reply =)

So I set up the Bios as you told me, although I didn’t find IEEE 1394 nor IOMMU settings on the bios.
I did disable VT-d and Onboard audio and hdmi… but after 12 hours it happened again. System froze. I am trying different videocards at a time to see if it’s hardware related, the mobo is brand new and it works, everything was working before on the other motherboard I replaced with this one. The only issue I had is that devices would stop being recognized and stop working, leaving me with 3 gpu’s where it0d be 4. Now it’s different as the whole system stops working.

I am now going to clean re-install all the drivers again (I have 3 1080 and 1 Amd r9) and see what happens. I remember I stopped having issues when I plugged the monitor to one of the videocards output when using the previous mobo…but that’s just a guess, I wish I knew the origin of the problem :confused:

P.S.: Some folks say MSI afterburner may cause trouble (it happened to me at first with EWBF but then I downgraded its version and nvidia driver to the same version I have on my other pc which works 24/7 with two 1080’s plugged to mobo without risers)


#4

First for AMD you have to have your monitor or a dummy plug into at minimum 1 AMD card or you will have driver issues. So in your setup with 1 AMD card you will need to either plug your monitor or a dummy plug into it in order for the driver to work properly.

After doing that if you still have issues I would remove all OC settings if any. Run and test stability. If everything works fine add OC settings for a single card. As you have 3 x 1080’s you will need to change the setting in MSI afterburner that sets the same setting for all like kind cards.

Will check back later after seeing the results of the above.


#5

Hey Nekko!

Okay! I remember I had issues like the ones you describe when my rig was set up with my former motherboard. Then I will plug the amd card to the monitor and see what happens.

Oh and to this point, there’s no overclock at all…I want to make sure the rig runs first.
The bios version is not the latest I see, but I will leave that to the end in case plugging the monitor to the AMD card doesn’t solve the issue.

As usual: Thank you very much!

Update: I set up the AMD card to be the primary display , it shows video and all but Claymore crashes, it won’t even mine a single share. At first the whole booting up was slow and it took it forever to display video. I set it to Pcie Gen 2 and now it works faster but it won’t mine

The system doesn’t freeze but it’s too early to tell as it usually freeze after some hours of work


#6

Good start, identifying the issue is often a process of elimination.

Take everything off, add one thing at a time and test it.

Also, do a quick check for a BIOS update, I’m very surprised IOMMU is a missing setting.
The IOMMU setting causes all sorts of grief, including your described “slow to post when booting”.

The reason it taking so long to post is because it is having conflicts, either memory or IRQ.

If it were me, I’d check for any updated BIOS firmware, then flash it, check settings, then try one card at a time to make sure they all work as individuals, then start with one, add one more and test and so on till you find what the limiting factor is.

Best of luck, I can’t tell you how many iterations I had to go through to get my Linux 12 x RX560 system going right, so I know what it is like :smile:

Stay Fishy


#7

Hey Mike!!

Thanks for your advise :slight_smile: , I think the bios update is what I’ll go for next.

I solved the "Claymore 64 stopped working " issue by DDUing all graphics drivers (including the onboard’s one). Then I installed AMD drivers first and then nvidia’s one. The reason I did it in that specific order is because something goes wrong when you install drivers otherwise (always speaking about hybrid rigs cases) and Claymore can’t execute AMD’s OpenCl… it would seem like AMD OpenCl gets replaced by nvidia’s one at the moment Claymore executes and that way it works but for some reason that won’t happen if you install AMD drivers after installing nvidia ones.

Another thing I think I did wrong is not plugging the riser on the right port. The designated PCI-E port to plug a VGA where a monitor will be plugged in is PCI-E 2 (as indicated on the mobo’s manual) and since all riser cables look the same and I have them all tied up to keep them in order, I plugged another VGA on PCI-E 2 instead of the 295x2.

Notice: OpenCl error and “Claymore stopped working” are two different things.

After doing that and making sure all ports were set to Gen 2 , post went back to normal when booting up, I could see OS load up animation and everything else normally.

I will keep updating the bios in mind whether or not the system fails again, as you recommended ;). Plus I’m also surprised IOMMU and IEEE 1394 don’t show up. At least IEEE 1394 should, I’ve seen that one in all the mobo’s I ever set up since I started building pc’s!

I am also not sure if Win 10 installed all drivers properly or if I’d download and install chipset drivers myself.

Thank you very much once again!!

I will keep this thread updated. If everything works for 24 hs straight, I will try overclocking the 3 GTX 1080’s on the main rig and see how that goes.

Have a great day!! :smile: :


#8

I would highly recommend installing your chipset drivers instead of relying on Windows.


#9

Awesome stuff, but when I said “take everything off” you were suppose to leave your clothes on!
Now I feel I need to go buy more Verge… LOL

Anyway, you might also want to check out xmr-stak:

Gets updated often and can run both the AMD OpenCL and NVidia CUDA together in the one program. The secret is to edit the config and set CPU affinity to true, so it pins the processes to a specific CPU core for running the GPU workers. Tends to be a bit more stable than running separate programs.

Stay Fishy


#10

Leaving virtualization settings enabled will not cause a mining rig to crash. Saying to disable those settings is just not good advice.

Disabling the Onboard Audio and Firewire/IEEE1394 ports will simply free up IRQs which a 4 GPU rig doesn’t require either.

You’re having the same issue I’m having on a Ubuntu 18 system lately. How many risers do you have plugged into a single SATA cable? More than 2? Or do you have a different type of riser that uses a different cable like molex or 6-pin direct to PSU?


#11

Hey guys!!
Sorry for the very late reply, I had a couple of things to take care of!

So everything has been working steady for more than a week now! @Nekko it all started when I set up my AMD card like you said : As my primary graphics adapter. Now the monitor is plugged there and no more problems!

@RedLineJoes, I learnt about NOT to plug more than 2 risers to a single sata power cable some months ago when my rig was suffering strong instability and the psu power port where that sata cable was melted down.
So nowadays I use one cable per riser. I do have different type of risers but that hasn’t caused me any issue so far. Setting up all PCIE ports to Gen 2 together with enabling 4G encoding helped big time, not only on my rig but also on my gaming pc which has a MSI motherboard (which have a tendency to be troublesome with configs when it comes to mining. MSI mobos also allow you to set latency. I set mine to 96 on that one, I have two gtx 1080 plugged to the mobo and one R9 fury x working with a riser)


#12

Awesome glad to hear it has been stable for more than a week.


#13

Thank you pal! And Thank you @Mike_Fishy!

Both your tips helped me fix the issue and gain a pretty good stability, and most importantly: I learned something new! :slight_smile: